summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2014-12-15 12:05:32 +0100
committerWerner Koch <wk@gnupg.org>2014-12-15 12:08:57 +0100
commitad50e360ef4851e66e51a03fc420175636336b58 (patch)
tree1951544c82725434ed9ff3b068591826fd7fb26c /Makefile.am
parent4f46374502eb988d701b904f83819e2cf7b1755c (diff)
downloadlibgcrypt-ad50e360ef4851e66e51a03fc420175636336b58.tar.gz
build: Add configure option --disable-doc.
* Makefile.am (AUTOMAKE_OPTIONS): Remove. (doc) [!BUILD_DOC]: Do not recurse into the dir. * configure.ac (AM_INIT_AUTOMAKE): Add option formerly in Makefile.am. (BUILD_DOC): Add new am_conditional.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 937bdaff..2d7ca433 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,15 +18,21 @@
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
ACLOCAL_AMFLAGS = -I m4
-AUTOMAKE_OPTIONS = dist-bzip2
-DISTCHECK_CONFIGURE_FLAGS = --disable-random-daemon \
+DISTCHECK_CONFIGURE_FLAGS = --disable-random-daemon --enable-doc \
--enable-ciphers=arcfour:blowfish:cast5:des:aes:twofish:serpent:rfc2268:seed:camellia
# (A suitable gitlog-to-changelog script can be found in GnuPG master.)
GITLOG_TO_CHANGELOG=gitlog-to-changelog
+if BUILD_DOC
+doc = doc
+else
+doc =
+endif
+
+
DIST_SUBDIRS = m4 compat mpi cipher random src doc tests
-SUBDIRS = compat mpi cipher random src doc tests
+SUBDIRS = compat mpi cipher random src $(doc) tests
EXTRA_DIST = autogen.sh autogen.rc README.GIT LICENSES \
ChangeLog-2011 build-aux/ChangeLog-2011 doc/ChangeLog-2011 \