summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2000-12-19 18:06:34 +0000
committerWerner Koch <wk@gnupg.org>2000-12-19 18:06:34 +0000
commitc0b5d7f57ab666e8f8f1e8fd11ec73389f579fba (patch)
tree32842ec4198f6e3f6c8e8ec4785d42973924ac0b /Makefile.am
parentc6debc4ab0ea77f42068541a487f6f2a0360c493 (diff)
downloadlibgcrypt-c0b5d7f57ab666e8f8f1e8fd11ec73389f579fba.tar.gz
First checkin og libgcrypt after splitting it out from GnuPG 1.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am50
1 files changed, 3 insertions, 47 deletions
diff --git a/Makefile.am b/Makefile.am
index 82971545..bc5a8bdc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,35 +1,8 @@
## Process this file with automake to produce Makefile.in
-#if COMPILE_LIBGCRYPT
-#gcrypt = gcrypt
-#my_clean_gcrypt =
-#else
-#gcrypt =
-#my_clean_gcrypt = gcrypt/Makefile
-#endif
-
-gcrypt = gcrypt
-my_clean_gcrypt =
-
-if CROSS_COMPILING
-checks =
-else
-checks = checks
-endif
-
-if COMPILE_AGENT
-agent = agent
-else
-agent =
-endif
-
-SUBDIRS = intl zlib jnlib util mpi cipher ${gcrypt} g10 po tools \
- ${agent} doc ${checks}
-EXTRA_DIST = README-alpha PROJECTS BUGS
-# gettext never gets it right, so we take here care of deleting the
-# symlink. my_clean_gcrypt is just a kludge until we can include
-# libgcrypt.
-DISTCLEANFILES = gnupg-defs.h intl/libintl.h ${my_clean_gcrypt}
+SUBDIRS = jnlib util mpi cipher src doc
+EXTRA_DIST = README-alpha BUGS
+DISTCLEANFILES = gcrypt-defs.h
# Add all the files listed in "distfiles" files to the distribution,
@@ -51,20 +24,3 @@ dist-hook:
echo "$(VERSION)" > $(distdir)/VERSION
-if MAINTAINER_MODE
-# This is only useful within my local environment (wk)
-cvs-get:
- rsync -Cavuzb --exclude scratch --exclude .deps \
- wkoch@sigtrap.guug.de:work/gnupg .
-
-cvs-put:
- rsync -Cavuzb --exclude .deps --exclude scratch \
- . wkoch@sigtrap.guug.de:work/gnupg
-
-cvs-sync: cvs-get cvs-put
-
-endif
-
-
-.PHONY: cvs-get cvs-put cvs-sync
-