summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2001-12-18 15:30:01 +0000
committerWerner Koch <wk@gnupg.org>2001-12-18 15:30:01 +0000
commiteb5e137dd74fefd8606606b2de835ca4e3bf235b (patch)
treef2afcc7e8e419346f8bc378cd7e87035a4515afd /Makefile.am
parent4d7c31417d7d49d839dad9016a0696a264229c3e (diff)
downloadlibgcrypt-eb5e137dd74fefd8606606b2de835ca4e3bf235b.tar.gz
* Makefile.am (dist-hook): Only look in mpi and scripts for
distfiles; this way we don't include those of a stale "make dist" directory. * acinclude.m4 (GNUPG_FIX_HDR_VERSION): Make it work with the new automake. * configure.ac: Don't chmod db2any.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 86e2813c..193cdc7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,16 +1,17 @@
## Process this file with automake to produce Makefile.in
SUBDIRS = jnlib mpi cipher src doc tests
-EXTRA_DIST = README-alpha BUGS
+EXTRA_DIST = README-alpha BUGS autogen.sh
DISTCLEANFILES = gcrypt-defs.h
# Add all the files listed in "distfiles" files to the distribution,
# apply version number s to some files and create a VERSION file which
-# we need for the Prereq: patch file trick.
+# we need for the Prereq: patch file trick.
dist-hook:
@set -e; \
- for file in `cd $(top_srcdir); find . -type f -name distfiles`; do \
+ for file in `cd $(top_srcdir); \
+ find mpi scripts -type f -name distfiles`; do \
dir=`dirname $$file` ; $(mkinstalldirs) $(distdir)/$$dir ; \
for i in distfiles `cat $(top_srcdir)/$$file` ; do \
ln $(top_srcdir)/$$dir/$$i $(distdir)/$$dir/$$i 2> /dev/null \
@@ -21,3 +22,6 @@ dist-hook:
echo "$(VERSION)" > $(distdir)/VERSION
+
+
+