summaryrefslogtreecommitdiff
path: root/cipher/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2013-09-07 10:06:46 +0200
committerWerner Koch <wk@gnupg.org>2013-09-19 16:43:33 +0200
commit071f70b9a766187fc70f6abc6a69d50752449285 (patch)
tree52508dcffe687cfa1385f010077d7ffb87c2fe20 /cipher/Makefile.am
parenteca9e2e50ddd4c9020fe1d4a9a3c77d20ebb90f6 (diff)
downloadlibgcrypt-071f70b9a766187fc70f6abc6a69d50752449285.tar.gz
pk: Move RSA encoding functions to a new file.
* cipher/rsa-common: New. * cipher/pubkey.c (pkcs1_encode_for_encryption): Move to rsa-common.c and rename to _gcry_rsa_pkcs1_encode_for_enc. (pkcs1_decode_for_encryption): Move to rsa-common.c and rename to _gcry_rsa_pkcs1_decode_for_enc. (pkcs1_encode_for_signature): Move to rsa-common.c and rename to _gcry_rsa_pkcs1_encode_for_sig. (oaep_encode): Move to rsa-common.c and rename to _gcry_rsa_oaep_encode. (oaep_decode): Move to rsa-common.c and rename to _gcry_rsa_oaep_decode. (pss_encode): Move to rsa-common.c and rename to _gcry_rsa_pss_encode. (pss_verify): Move to rsa-common.c and rename to _gcry_rsa_pss_decode. (octet_string_from_mpi, mgf1): Move to rsa-common.c. Signed-off-by: Werner Koch <wk@gnupg.org>
Diffstat (limited to 'cipher/Makefile.am')
-rw-r--r--cipher/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cipher/Makefile.am b/cipher/Makefile.am
index 49d4cee3..cce12c2e 100644
--- a/cipher/Makefile.am
+++ b/cipher/Makefile.am
@@ -49,7 +49,7 @@ bithelp.h \
bufhelp.h \
primegen.c \
hash-common.c hash-common.h \
-dsa-common.c \
+dsa-common.c rsa-common.c \
rmd.h
EXTRA_libcipher_la_SOURCES = \