summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2012-11-05 19:38:58 +0100
committerWerner Koch <wk@gnupg.org>2012-11-05 19:38:58 +0100
commit1241fbbc896e9bbad68f1007a17b20493f6cd1af (patch)
tree517d8ceb912b4b2063424df7a81c80f0f100e45b /configure.ac
parenta5c4d45e8d12737cd21b095c81da5c18e2afc39e (diff)
downloadlibgcrypt-1241fbbc896e9bbad68f1007a17b20493f6cd1af.tar.gz
Adjust for stricter autoconf requirements.
* configure.ac: Fix usage of AC_LANG_PROGRAM.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 12eda4db..b152c0f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -773,7 +773,7 @@ if test "$gcry_cv_visibility_attribute" = "yes"; then
[gcry_cv_gcc_has_f_visibility=no
_gcc_cflags_save=$CFLAGS
CFLAGS="-fvisibility=hidden"
- AC_COMPILE_IFELSE(AC_LANG_PROGRAM([]),
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])],
gcry_cv_gcc_has_f_visibility=yes)
CFLAGS=$_gcc_cflags_save;
])
@@ -973,7 +973,7 @@ if test "$GCC" = yes; then
AC_MSG_CHECKING([if gcc supports -Wno-missing-field-initializers])
_gcc_cflags_save=$CFLAGS
CFLAGS="-Wno-missing-field-initializers"
- AC_COMPILE_IFELSE(AC_LANG_PROGRAM([]),_gcc_wopt=yes,_gcc_wopt=no)
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])],_gcc_wopt=yes,_gcc_wopt=no)
AC_MSG_RESULT($_gcc_wopt)
CFLAGS=$_gcc_cflags_save;
if test x"$_gcc_wopt" = xyes ; then
@@ -987,7 +987,7 @@ if test "$GCC" = yes; then
AC_MSG_CHECKING([if gcc supports -Wpointer-arith])
_gcc_cflags_save=$CFLAGS
CFLAGS="-Wpointer-arith"
- AC_COMPILE_IFELSE(AC_LANG_PROGRAM([]),_gcc_wopt=yes,_gcc_wopt=no)
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])],_gcc_wopt=yes,_gcc_wopt=no)
AC_MSG_RESULT($_gcc_wopt)
CFLAGS=$_gcc_cflags_save;
if test x"$_gcc_wopt" = xyes ; then