summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2014-10-02 12:51:49 +0200
committerWerner Koch <wk@gnupg.org>2014-10-02 13:20:46 +0200
commit1e8b86494cf8fa045696bd447b16267ffd1797f0 (patch)
treee97afae2dd5ab3fe5bd3bfc00a897df2aabda6a6 /configure.ac
parent51dae8c8c4b63bb5e1685cbd8722e35342524737 (diff)
downloadlibgcrypt-1e8b86494cf8fa045696bd447b16267ffd1797f0.tar.gz
build: Support SYSROOT based config script finding.
* src/libgcrypt.m4: Add support for SYSROOT and set gpg_config_script_warn. Use AC_PATH_PROG instead of AC_PATH_TOOL because the config script is not expected to be installed with a prefix for its name * configure.ac: Print a library mismatch warning. * m4/gpg-error.m4: Update from git master. -- Also fixed the false copyright notice in libgcrypt.m4.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c5952c7d..baed3ecc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2123,9 +2123,17 @@ GCRY_MSG_SHOW([Try using Intel AVX2: ],[$avx2support])
GCRY_MSG_SHOW([Try using ARM NEON: ],[$neonsupport])
GCRY_MSG_SHOW([],[])
-if test "$print_egd_notice" = "yes"; then
+if test "x${gpg_config_script_warn}" != x; then
cat <<G10EOF
+ Mismatches between the target platform and the to
+ be used libraries have been been detected for:
+ ${gpg_config_script_warn}
+ Please check above for warning messages.
+G10EOF
+fi
+if test "$print_egd_notice" = "yes"; then
+cat <<G10EOF
The performance of the Unix random gatherer module (rndunix) is not
very good and it does not keep the entropy pool over multiple
invocations of Libgcrypt base applications. The suggested way to
@@ -2145,7 +2153,6 @@ fi
if test "$gcry_cv_gcc_attribute_aligned" != "yes" ; then
cat <<G10EOF
-
Please not that your compiler does not support the GCC style
aligned attribute. Using this software may evoke bus errors.
@@ -2157,4 +2164,5 @@ if test -n "$gpl"; then
echo " $gpl"
echo "included. These parts are licensed under the GPL and thus the"
echo "use of this library has to comply with the conditions of the GPL."
+ echo ""
fi