summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2006-08-29 10:21:09 +0000
committerWerner Koch <wk@gnupg.org>2006-08-29 10:21:09 +0000
commit514c81214ca86a3aa1ec2e0523e407acd7e7d0b5 (patch)
treeb3739d07029c45eb0b0e276de11f1756068db6e7 /configure.ac
parent3731976da915a9f721614c4fdf557ed3cea33895 (diff)
downloadlibgcrypt-514c81214ca86a3aa1ec2e0523e407acd7e7d0b5.tar.gz
Added SEED cipher
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9f21c94b..bcbea2e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,7 +112,7 @@ LIBGCRYPT_CONFIG_LIBS="-lgcrypt"
LIBGCRYPT_CONFIG_CFLAGS=""
# Definitions for symmetric ciphers.
-available_ciphers="arcfour blowfish cast5 des aes twofish serpent rfc2268"
+available_ciphers="arcfour blowfish cast5 des aes twofish serpent rfc2268 seed"
enabled_ciphers=""
# Definitions for public-key ciphers.
@@ -757,6 +757,11 @@ test "$found" = "1" && GCRYPT_CIPHERS="$GCRYPT_CIPHERS rfc2268.lo"
AC_DEFINE_UNQUOTED(USE_RFC2268, $found,
[Defined if this module should be included])
+LIST_MEMBER(seed, $enabled_ciphers)
+test "$found" = "1" && GCRYPT_CIPHERS="$GCRYPT_CIPHERS seed.lo"
+AC_DEFINE_UNQUOTED(USE_SEED, $found,
+ [Defined if this module should be included])
+
LIST_MEMBER(dsa, $enabled_pubkey_ciphers)
test "$found" = "1" && GCRYPT_PUBKEY_CIPHERS="$GCRYPT_PUBKEY_CIPHERS dsa.lo"
AC_DEFINE_UNQUOTED(USE_DSA, $found,