summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Brinkmann <mb@g10code.com>2004-03-11 01:44:44 +0000
committerMarcus Brinkmann <mb@g10code.com>2004-03-11 01:44:44 +0000
commit7995b7f73dce3b2b48d85066fca134cb24b8a4dc (patch)
tree8d544b18e7cc5b6ff45e26f182674d8df0c4978f /configure.ac
parentfe6cf2d0fb865f9d6c1d0944a8c128c8d4f70989 (diff)
downloadlibgcrypt-7995b7f73dce3b2b48d85066fca134cb24b8a4dc.tar.gz
2004-03-10 Marcus Brinkmann <marcus@g10code.de>
* configure.ac (LIBGCRYPT_CONFIG_LIBS_PTHREAD, LIBGCRYPT_CONFIG_CFLAGS_PTHREAD, LIBGCRYPT_CONFIG_LIBS_PTH, LIBGCRYPT_CONFIG_CFLAGS_PTH, have_pth, have_pthread, AC_CHECK_PTH, AC_CHECK_LIB(pthread), HAVE_PTH, HAVE_PTHREAD): Removed. doc/ 2004-03-11 Marcus Brinkmann <marcus@g10code.de> * gcrypt.texi (Multi Threading): Partially document new thread support. src/ 2004-03-10 Marcus Brinkmann <marcus@g10code.de> * Makefile.am (ltlib_libgcrypt_pthread, ltlib_libgcrypt_pth): Removed. (lib_LTLIBRARIES): Remove those variables from here. (libgcrypt_pthread_la_SOURCES, libgcrypt_pthread_la_LDFLAGS, (libgcrypt_pthread_la_DEPENDENCIES, libgcrypt_pthread_la_LIBADD, (libgcrypt_pth_la_SOURCES, libgcrypt_pth_la_LDFLAGS, (libgcrypt_pth_la_DEPENDENCIES, libgcrypt_pth_la_LIBADD, (noinst_LTLIBRARIES): Removed. (libgcrypt_real_la_SOURCES): Merge with ... (libgcrypt_la_SOURCES): ... likewise. (libgcrypt_real_la_DEPENDENCIES): Merge with ... (libgcrypt_la_DEPENDENCIES): ... this. (libgcrypt_real_la_LIBADD): Merge with ... (libgcrypt_la_LIBADD): ... this. * libgcrypt-config.in (libs_pthread, libs_pth, cflags_pth) (cflags_pthread, thread_module, thread_modules): Removed. (Options): Remove --thread option from help output. If the option is specified, output an error and exit. For --cflags and --libs option, remove pth and pthread from output. * gcrypt.h: Include <sys/types.h> and <sys/socket.h>. (enum gcry_ctl_cmds): Add GCRYCTL_SET_THREAD_CBS. (gcry_thread_cbs): New struct. * global.c (gcry_control): Implement GCRYCTL_SET_THREAD_CBS. (global_init): Don't call ath_init here. * ath.h: Rewritten. * ath.c: Rewritten.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 0 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 61eced60..c07f53ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,10 +85,6 @@ AC_DEFINE_UNQUOTED(VERSION, "$VERSION", [Version of this package])
# Used by libgcrypt-config
LIBGCRYPT_CONFIG_LIBS="-lgcrypt"
LIBGCRYPT_CONFIG_CFLAGS=""
-LIBGCRYPT_CONFIG_LIBS_PTHREAD="-lgcrypt-pthread"
-LIBGCRYPT_CONFIG_CFLAGS_PTHREAD=""
-LIBGCRYPT_CONFIG_LIBS_PTH="-lgcrypt-pth"
-LIBGCRYPT_CONFIG_CFLAGS_PTH=""
# Definitions for symmetric ciphers.
available_ciphers="arcfour blowfish cast5 des aes twofish serpent rfc2268"
@@ -493,31 +489,6 @@ AC_CHECK_FUNCS(gettimeofday getrusage gethrtime clock_gettime)
GNUPG_CHECK_MLOCK
-# Check which thread libraries are supported by the system.
-have_pth=no
-have_pthread=no
-
-AC_CHECK_PTH(1.2.0,,,no,have_pth=yes)
-if test "$have_pth" = yes; then
- LIBGCRYPT_CONFIG_LIBS_PTH="$LIBGCRYPT_CONFIG_LIBS_PTH -lpth"
- LIBGCRYPT_THREAD_MODULES="$LIBGCRYPT_THREAD_MODULES pth"
- AC_DEFINE(HAVE_PTH, ,[Define if we have Pth.])
-fi
-
-AC_CHECK_LIB(pthread,pthread_create,have_pthread=yes)
-if test "$have_pthread" = yes; then
- LIBGCRYPT_CONFIG_LIBS_PTHREAD="$LIBGCRYPT_CONFIG_LIBS_PTHREAD -lpthread"
-else
- AC_CHECK_LIB(c,pthread_create,have_pthread=yes)
-fi
-if test "$have_pthread" = yes; then
- LIBGCRYPT_THREAD_MODULES="$LIBGCRYPT_THREAD_MODULES pthread"
- AC_DEFINE(HAVE_PTHREAD, ,[Define if we have pthread.])
-fi
-
-AM_CONDITIONAL(HAVE_PTH, test "$have_pth" = "yes")
-AM_CONDITIONAL(HAVE_PTHREAD, test "$have_pthread" = "yes")
-
# Check whether we can use Linux capabilities as requested.
if test "$use_capabilities" = "yes" ; then
use_capabilities=no
@@ -660,10 +631,6 @@ GNUPG_FIX_HDR_VERSION([src/gcrypt.h], GCRYPT_VERSION)
AC_SUBST(LIBGCRYPT_CONFIG_API_VERSION)
AC_SUBST(LIBGCRYPT_CONFIG_LIBS)
AC_SUBST(LIBGCRYPT_CONFIG_CFLAGS)
-AC_SUBST(LIBGCRYPT_CONFIG_LIBS_PTHREAD)
-AC_SUBST(LIBGCRYPT_CONFIG_CFLAGS_PTHREAD)
-AC_SUBST(LIBGCRYPT_CONFIG_LIBS_PTH)
-AC_SUBST(LIBGCRYPT_CONFIG_CFLAGS_PTH)
AC_SUBST(LIBGCRYPT_THREAD_MODULES)
AC_CONFIG_COMMANDS([gcrypt-conf],[[