summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2007-03-22 13:55:05 +0000
committerWerner Koch <wk@gnupg.org>2007-03-22 13:55:05 +0000
commit96422a1a5059b9352f55488f2b47dfd6dfa0b423 (patch)
treea940054b35e1d55ba6635100d58628f95898b971 /configure.ac
parent5fb3fe0e58466d9556839cd7b5cfaab9468dd0cd (diff)
downloadlibgcrypt-96422a1a5059b9352f55488f2b47dfd6dfa0b423.tar.gz
Experimental support for ECDSA.
This is not ready but the key generation and the self-test works.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 58a50845..1ad646ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,7 +135,7 @@ available_ciphers="arcfour blowfish cast5 des aes twofish serpent rfc2268 seed"
enabled_ciphers=""
# Definitions for public-key ciphers.
-available_pubkey_ciphers="dsa elgamal rsa"
+available_pubkey_ciphers="dsa elgamal rsa ecc"
enabled_pubkey_ciphers=""
# Definitions for message digests.
@@ -825,6 +825,12 @@ test "$found" = "1" \
AC_DEFINE_UNQUOTED(USE_ELGAMAL, $found,
[Defined if this module should be included])
+LIST_MEMBER(ecc, $enabled_pubkey_ciphers)
+test "$found" = "1" \
+ && GCRYPT_PUBKEY_CIPHERS="$GCRYPT_PUBKEY_CIPHERS ecc.lo"
+AC_DEFINE_UNQUOTED(USE_ECC, $found,
+ [Defined if this module should be included])
+
LIST_MEMBER(crc, $enabled_digests)
test "$found" = "1" && GCRYPT_DIGESTS="$GCRYPT_DIGESTS crc.lo"
AC_DEFINE_UNQUOTED(USE_CRC, $found,