summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2014-12-15 12:05:32 +0100
committerWerner Koch <wk@gnupg.org>2014-12-15 12:08:57 +0100
commitad50e360ef4851e66e51a03fc420175636336b58 (patch)
tree1951544c82725434ed9ff3b068591826fd7fb26c /configure.ac
parent4f46374502eb988d701b904f83819e2cf7b1755c (diff)
downloadlibgcrypt-ad50e360ef4851e66e51a03fc420175636336b58.tar.gz
build: Add configure option --disable-doc.
* Makefile.am (AUTOMAKE_OPTIONS): Remove. (doc) [!BUILD_DOC]: Do not recurse into the dir. * configure.ac (AM_INIT_AUTOMAKE): Add option formerly in Makefile.am. (BUILD_DOC): Add new am_conditional.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c979d571..a4ea990d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,7 +75,7 @@ VERSION=$PACKAGE_VERSION
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_SRCDIR([src/libgcrypt.vers])
-AM_INIT_AUTOMAKE
+AM_INIT_AUTOMAKE([dist-bzip2])
AC_CONFIG_HEADER(config.h)
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_LIBOBJ_DIR([compat])
@@ -2090,6 +2090,16 @@ AC_SUBST([GCRYPT_HWF_MODULES])
#
+# Option to disable building of doc file
+#
+build_doc=yes
+AC_ARG_ENABLE([doc], AC_HELP_STRING([--disable-doc],
+ [do not build the documentation]),
+ build_doc=$enableval, build_doc=yes)
+AM_CONDITIONAL([BUILD_DOC], [test "x$build_doc" != xno])
+
+
+#
# Provide information about the build.
#
BUILD_REVISION="mym4_revision"