summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2013-09-18 14:34:18 +0200
committerWerner Koch <wk@gnupg.org>2013-09-18 14:35:08 +0200
commitc22064bdd773a807801e300aa9214b2fdcafcf20 (patch)
treea45813dbbd6b94a988478c02a763aef25680b5c5 /configure.ac
parentb0579baaa04fb91eabbbdc295bcabea04cf84056 (diff)
downloadlibgcrypt-c22064bdd773a807801e300aa9214b2fdcafcf20.tar.gz
Add GOST R 34.11-2012 implementation (Stribog)
* src/gcrypt.h.in (GCRY_MD_GOSTR3411_12_256) (GCRY_MD_GOSTR3411_12_512): New. * cipher/stribog.c: New. * configure.ac (available_digests_64): Add stribog. * src/cipher.h: Declare Stribog declarations. * cipher/md.c: Register Stribog digest. * tests/basic.c (check_digests) Add 4 testcases for Stribog from standard. * doc/gcrypt.texi: Document new constants. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f7000801..91bbf4b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,7 +193,7 @@ enabled_pubkey_ciphers=""
# Definitions for message digests.
available_digests="crc gostr3411-94 md4 md5 rmd160 sha1 sha256"
-available_digests_64="sha512 tiger whirlpool"
+available_digests_64="sha512 tiger whirlpool stribog"
enabled_digests=""
# Definitions for kdfs (optional ones)
@@ -354,7 +354,7 @@ if test "$ac_cv_sizeof_unsigned_int" != "8" \
&& test "$ac_cv_sizeof_unsigned_long_long" != "8" \
&& test "$ac_cv_sizeof_uint64_t" != "8"; then
AC_MSG_WARN([No 64-bit types. Disabling TIGER/192, SCRYPT, SHA-384, \
- and SHA-512])
+ SHA-512 and GOST R 34.11-12])
else
available_digests="$available_digests $available_digests_64"
available_kdfs="$available_kdfs $available_kdfs_64"
@@ -1548,6 +1548,12 @@ if test "$found" = "1" ; then
fi
fi
+LIST_MEMBER(stribog, $enabled_digests)
+if test "$found" = "1" ; then
+ GCRYPT_DIGESTS="$GCRYPT_DIGESTS stribog.lo"
+ AC_DEFINE(USE_GOST_R_3411_12, 1, [Defined if this module should be included])
+fi
+
LIST_MEMBER(md4, $enabled_digests)
if test "$found" = "1" ; then
GCRYPT_DIGESTS="$GCRYPT_DIGESTS md4.lo"