summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2013-03-07 14:13:33 +0100
committerWerner Koch <wk@gnupg.org>2013-03-07 14:13:33 +0100
commitc620099e4ab2f35e0196b395a805bb655c984ac2 (patch)
treeb6ff6f267a3aa795f210d6104bbaa9dec1b1c0a6 /configure.ac
parent70dcac663de06b012417015c175973d64e6980df (diff)
downloadlibgcrypt-c620099e4ab2f35e0196b395a805bb655c984ac2.tar.gz
Pretty print the configure feedback.
* acinclude.m4 (GNUPG_MSG_PRINT): Remove. (GCRY_MSG_SHOW, GCRY_MSG_WRAP): New. * configure.ac: Use new macros for the feedback.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 15 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 1f057f79..7afd83d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1380,21 +1380,21 @@ detection_module="${GCRYPT_HWF_MODULES%.lo}"
test -n "$detection_module" || detection_module="none"
# Give some feedback
-echo "
- Libgcrypt v${VERSION} has been configured as follows:
-
- Platform: $PRINTABLE_OS_NAME ($host)
- Hardware detection module: $detection_module
- Enabled cipher algorithms: $enabled_ciphers
- Enabled digest algorithms: $enabled_digests
- Enabled pubkey algorithms: $enabled_pubkey_ciphers
- Random number generator: $random
- Using linux capabilities: $use_capabilities
- Try using Padlock crypto: $padlocksupport
- Try using AES-NI crypto: $aesnisupport
- Try using DRNG (RDRAND): $drngsupport
- Try using Intel AVX: $avxsupport
-"
+GCRY_MSG_SHOW([],[])
+GCRY_MSG_SHOW([Libgcrypt],[v${VERSION} has been configured as follows:])
+GCRY_MSG_SHOW([],[])
+GCRY_MSG_SHOW([Platform: ],[$PRINTABLE_OS_NAME ($host)])
+GCRY_MSG_SHOW([Hardware detection module:],[$detection_module])
+GCRY_MSG_WRAP([Enabled cipher algorithms:],[$enabled_ciphers])
+GCRY_MSG_WRAP([Enabled digest algorithms:],[$enabled_digests])
+GCRY_MSG_WRAP([Enabled pubkey algorithms:],[$enabled_pubkey_ciphers])
+GCRY_MSG_SHOW([Random number generator: ],[$random])
+GCRY_MSG_SHOW([Using linux capabilities: ],[$use_capabilities])
+GCRY_MSG_SHOW([Try using Padlock crypto: ],[$padlocksupport])
+GCRY_MSG_SHOW([Try using AES-NI crypto: ],[$aesnisupport])
+GCRY_MSG_SHOW([Try using DRNG (RDRAND): ],[$drngsupport])
+GCRY_MSG_SHOW([Try using Intel AVX: ],[$avxsupport])
+GCRY_MSG_SHOW([],[])
if test "$print_egd_notice" = "yes"; then
cat <<G10EOF