summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2011-02-18 14:30:13 +0100
committerWerner Koch <wk@gnupg.org>2011-02-18 14:30:13 +0100
commitf17d50bbd31b1faa24af1e46c10bba845becf585 (patch)
tree3fafbfc3613d7bbed1db2dec03d5a61321a61f99 /configure.ac
parentdc880b55f4bb27d20c0224338836ac0505f386ff (diff)
downloadlibgcrypt-f17d50bbd31b1faa24af1e46c10bba845becf585.tar.gz
Fix strict-aliasing problems in rijndael.c
We used to use -fno-strict-aliasing but only if configured in maintainer-mode. Thus with gcc-4.4 we could run into problems. The fix is to define a new type with the may_alias attribute and use this for the casting stuff in do_encrypt_aligned and do_decrypt_aligned.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 64692b6d..013ff3af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -951,17 +951,6 @@ if test "$GCC" = yes; then
if test x"$_gcc_wopt" = xyes ; then
CFLAGS="$CFLAGS -Wpointer-arith"
fi
-
- AC_MSG_CHECKING([if gcc supports -fno-strict-aliasing])
- _gcc_cflags_save=$CFLAGS
- CFLAGS="-fno-strict-aliasing"
- AC_COMPILE_IFELSE(AC_LANG_PROGRAM([]),_gcc_wopt=yes,_gcc_wopt=no)
- AC_MSG_RESULT($_gcc_wopt)
- CFLAGS=$_gcc_cflags_save;
- if test x"$_gcc_wopt" = xyes ; then
- CFLAGS="$CFLAGS -fno-strict-aliasing"
- fi
-
fi
fi
@@ -1228,6 +1217,8 @@ echo "
Enabled pubkey algorithms: $enabled_pubkey_ciphers
Random number generator: $random
Using linux capabilities: $use_capabilities
+ Try using Padlock crypto: $padlocksupport
+ Try using AES-NI crypto: $aesnisupport
"
if test "$print_egd_notice" = "yes"; then