summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2014-01-09 19:14:09 +0100
committerWerner Koch <wk@gnupg.org>2014-01-27 14:19:56 +0100
commitf7df906171854b6b6506b82d4fee2c2ebb0327ea (patch)
tree1f0bc7a1c7b412d9c4b73b54560187c201601f41 /configure.ac
parent79da0358fd555361e1ce4202f55494a8918eb8ae (diff)
downloadlibgcrypt-f7df906171854b6b6506b82d4fee2c2ebb0327ea.tar.gz
Small Windows build tweaks.
* configure.ac (HAVE_PTHREAD): Do test when building for Windows. * tests/basic.c: Replace "%zi" by "%z" and a cast to make it work under Windows. Signed-off-by: Werner Koch <wk@gnupg.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4d16fc69..62544533 100644
--- a/configure.ac
+++ b/configure.ac
@@ -729,9 +729,11 @@ AC_SUBST(PTH_LIBS)
#
# Check whether pthreads is available
#
-AC_CHECK_LIB(pthread,pthread_create,have_pthread=yes)
-if test "$have_pthread" = yes; then
- AC_DEFINE(HAVE_PTHREAD, 1 ,[Define if we have pthread.])
+if test "$have_w32_system" != yes; then
+ AC_CHECK_LIB(pthread,pthread_create,have_pthread=yes)
+ if test "$have_pthread" = yes; then
+ AC_DEFINE(HAVE_PTHREAD, 1 ,[Define if we have pthread.])
+ fi
fi