summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>1999-06-16 18:25:39 +0000
committerWerner Koch <wk@gnupg.org>1999-06-16 18:25:39 +0000
commitdaea8299d0f5eb05b2325fc436185dea73c6c9be (patch)
tree246fac3a5f5f6ce4168198efb074eeb64cf8a9ec /doc/Makefile.am
parent560c840faa105d8ddc1f4d6e8c745d8bc1a3ea72 (diff)
downloadlibgcrypt-daea8299d0f5eb05b2325fc436185dea73c6c9be.tar.gz
See ChangeLog: Wed Jun 16 20:16:21 CEST 1999 Werner Koch
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 460a63db..26f83e32 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,25 +1,23 @@
## Process this file with automake to create Makefile.in
-EXTRA_DIST = DETAILS gpg.1pod gpg.1 FAQ HACKING OpenPGP
+EXTRA_DIST = DETAILS gpg.sgml gpg.1 FAQ HACKING OpenPGP
man_MANS = gpg.1
-
-%: %pod
- pod2man $< --section=`echo $@ | sed 's/^.*(?)$$/$$&/'`\
- --release="`date -r $< '+%d %b %Y'`"\
- --center="GNU Tools" --date=' '\
- >$@,$$$$ && mv -f $@,$$$$ $@\
- || rm -f $@,$$$$
-
+%.1 : %.sgml
+if HAVE_DOCBOOK_TO_MAN
+ docbook-to-man $< >$@
+else
+ : Warning: missing docbook-to-man, cannot make $@
+endif
%.txt : %.sgml
sgml2txt -c latin $*
%.html : %.sgml
- sgml2html -l deutsch -c latin $*
+ sgml2html -c latin $*
%.dvi : %.sgml
-rm $*.sgml.tmp