summaryrefslogtreecommitdiff
path: root/mpi/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>1999-07-14 17:47:19 +0000
committerWerner Koch <wk@gnupg.org>1999-07-14 17:47:19 +0000
commit36a06a94b54f8176c669fab51a7b4258116555b1 (patch)
tree05f599cf5908de1bb4fd3064ee7bd6f1cc7c1674 /mpi/Makefile.am
parentd5fd397c6b8d4b98630e41e55bfa43c617a06eec (diff)
downloadlibgcrypt-36a06a94b54f8176c669fab51a7b4258116555b1.tar.gz
See ChangeLog: Wed Jul 14 19:42:08 CEST 1999 Werner Koch
Diffstat (limited to 'mpi/Makefile.am')
-rw-r--r--mpi/Makefile.am23
1 files changed, 9 insertions, 14 deletions
diff --git a/mpi/Makefile.am b/mpi/Makefile.am
index e5c241a2..ef9816aa 100644
--- a/mpi/Makefile.am
+++ b/mpi/Makefile.am
@@ -1,5 +1,6 @@
## Process this file with automake to produce Makefile.in
+
INCLUDES = -I$(top_srcdir)/include
CFLAGS = @CFLAGS@ @MPI_OPT_FLAGS@
SFLAGS = @MPI_SFLAGS@
@@ -7,7 +8,8 @@ SFLAGS = @MPI_SFLAGS@
EXTRA_DIST = config.links
DISTCLEANFILES = mpih-add1.S mpih-mul1.S mpih-mul2.S mpih-mul3.S \
mpih-lshift.S mpih-rshift.S mpih-sub1.S asm-syntax.h sysdep.h
-CLEANFILES = tmp-*.s
+# Note: we only use .S files so we should delete all left over .s
+CLEANFILES = *.s
noinst_LTLIBRARIES = libmpi.la
@@ -46,20 +48,13 @@ common_asm_objects = mpih-mul1.lo \
libmpi_la_DEPENDENCIES = $(common_asm_objects) @MPI_EXTRA_ASM_OBJS@
libmpi_la_LIBADD = $(common_asm_objects) @MPI_EXTRA_ASM_OBJS@
-SUFFIXES = .S
-
+# cancel the default rules used by libtool which do not really
+# work and add one to cpp .S files
.S.o:
- $(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' >tmp-$*.s
- $(CC) $(CFLAGS) $(SFLAGS) -c tmp-$*.s
- mv tmp-$*.o $@
- rm -f tmp-$*.s
.S.lo:
- $(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' >tmp-$*.s
- if test -f tmp-$*.lo; then rm tmp-$*.lo; fi
- if test -f tmp-$*.o ; then rm tmp-$*.o ; fi
- $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(SFLAGS) -c tmp-$*.s
- if test -f tmp-$*.lo; then mv tmp-$*.lo $*.lo; fi
- if test -f tmp-$*.o ; then mv tmp-$*.o $*.o ; fi
- rm -f tmp-$*.s
+
+.S.s:
+ $(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' >$*.s
+