summaryrefslogtreecommitdiff
path: root/mpi/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2002-08-23 18:41:37 +0000
committerWerner Koch <wk@gnupg.org>2002-08-23 18:41:37 +0000
commit468a6913f0bc50586f092f67478cb5e58b21a0ce (patch)
tree55066076b6c2f3fd3e0ee859d01275d4831a2b49 /mpi/Makefile.am
parent1f33736a7a2bc4734d1096ddf8e2468662ba7de6 (diff)
downloadlibgcrypt-468a6913f0bc50586f092f67478cb5e58b21a0ce.tar.gz
* Makefile.am (.S.lo): Fixed for libtool build with --disable-shared.
Diffstat (limited to 'mpi/Makefile.am')
-rw-r--r--mpi/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/mpi/Makefile.am b/mpi/Makefile.am
index 36ee2f66..1a2d5933 100644
--- a/mpi/Makefile.am
+++ b/mpi/Makefile.am
@@ -34,7 +34,7 @@ EXTRA_DIST = config.links
DISTCLEANFILES = mpih-add1.S mpih-mul1.S mpih-mul2.S mpih-mul3.S \
mpih-lshift.S mpih-rshift.S mpih-sub1.S asm-syntax.h sysdep.h
# Note: we only use .S files so we should delete all left over .s
-CLEANFILES = _*.s
+CLEANFILES = _*.s __*.s
# Beware: The following list is not a comment but grepped by
# config.links to get the list of symlinked modules
@@ -174,12 +174,14 @@ libmpi_la_LIBADD = @MPI_MOD_LIST_LO@
libmpi_la_DEPENDENCIES = @MPI_MOD_LIST_LO@
# we need our own rules here to preprocess the .S files
+# libtool has now working support for assembiles. It does for example not
+# work when building only a static library.
.S.o:
$(CPP) $(INCLUDES) $(DEFS) `test -f '$<' || echo '$(srcdir)/'`$< | grep -v '^#' > _$*.s
$(CCASCOMPILE) -c _$*.s
mv -f _$*.o $@
.S.lo:
- $(CPP) $(INCLUDES) $(DEFS) `test -f '$<' || echo '$(srcdir)/'`$< | grep -v '^#' > _$*.s
- $(LTCCASCOMPILE) -c _$*.s
- mv -f _$*.lo $@
+ $(CPP) $(INCLUDES) $(DEFS) `test -f '$<' || echo '$(srcdir)/'`$< | grep -v '^#' > __$*.s
+ $(CCASCOMPILE) -c __$*.s
+ mv -f __$*.o $@