summaryrefslogtreecommitdiff
path: root/mpi/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2000-07-17 14:32:20 +0000
committerWerner Koch <wk@gnupg.org>2000-07-17 14:32:20 +0000
commit487fe72494051de4a7e513c15b6a895dcd0164ce (patch)
tree82411404fe06df0c1c98193275ec2055c52ec016 /mpi/Makefile.am
parent74386120dad6b3da62db37f7044267c8ef34689b (diff)
downloadlibgcrypt-487fe72494051de4a7e513c15b6a895dcd0164ce.tar.gz
See ChangeLog: Mon Jul 17 16:35:47 CEST 2000 Werner Koch
Diffstat (limited to 'mpi/Makefile.am')
-rw-r--r--mpi/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/mpi/Makefile.am b/mpi/Makefile.am
index 98ad5fcc..f7567e5f 100644
--- a/mpi/Makefile.am
+++ b/mpi/Makefile.am
@@ -3,12 +3,13 @@
INCLUDES = -I$(top_srcdir)/gcrypt
CFLAGS = @CFLAGS@ @MPI_OPT_FLAGS@
-SFLAGS = @MPI_SFLAGS@
+ASFLAGS = @MPI_SFLAGS@
EXTRA_DIST = config.links
DISTCLEANFILES = mpih-add1.S mpih-mul1.S mpih-mul2.S mpih-mul3.S \
mpih-lshift.S mpih-rshift.S mpih-sub1.S asm-syntax.h sysdep.h
# Note: we only use .S files so we should delete all left over .s
+# CLEANFILES = _*.s
CLEANFILES = *.s
noinst_LTLIBRARIES = libmpi.la
@@ -56,4 +57,9 @@ libmpi_la_LIBADD = $(common_asm_objects) @MPI_EXTRA_ASM_OBJS@
.S.s:
$(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' >$*.s
+# Hmmm, we should use this, so that OSes which do not distinguish
+# filename case still work. We have to see how libtool can handle this
+# $(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' > _$*.s
+# $(COMPILE) -c _$*.s
+# mv -f _$*.o $*.o