summaryrefslogtreecommitdiff
path: root/mpi/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>1997-11-26 21:06:44 +0000
committerWerner Koch <wk@gnupg.org>1997-11-26 21:06:44 +0000
commit55aefe3378aea76c3bfe3bf290d8b7d74bed133a (patch)
treef7b025ec8697d87260c98c05415bf95f901fd099 /mpi/Makefile.am
parent7927452093826608e9e29f3ac13166415dabf46c (diff)
downloadlibgcrypt-55aefe3378aea76c3bfe3bf290d8b7d74bed133a.tar.gz
changed the dir layout
Diffstat (limited to 'mpi/Makefile.am')
-rw-r--r--mpi/Makefile.am45
1 files changed, 27 insertions, 18 deletions
diff --git a/mpi/Makefile.am b/mpi/Makefile.am
index 5edd90c2..353ab23a 100644
--- a/mpi/Makefile.am
+++ b/mpi/Makefile.am
@@ -1,27 +1,36 @@
## Process this file with automake to produce Makefile.in
INCLUDES = -I$(top_srcdir)/include
+CFLAGS += -O2
noinst_LIBRARIES = mpi
-mpi_SOURCES = longlong.h \
- mpi-add.c \
- mpi-bit.c \
- mpi-cmp.c \
- mpi-div.c \
- mpi-gcd.c \
- mpi-internal.h \
- mpi-inv.c \
- mpi-mul.c \
- mpi-pow.c \
- mpi-scan.c \
- mpicoder.c \
- mpihelp-add.c \
- mpihelp-cmp.c \
- mpihelp-div.c \
- mpihelp-mul.c \
- mpihelp-shift.c \
- mpihelp-sub.c \
+mpi_SOURCES = longlong.h \
+ mpi-add.c \
+ mpi-bit.c \
+ mpi-cmp.c \
+ mpi-div.c \
+ mpi-gcd.c \
+ mpi-internal.h \
+ mpi-inline.h \
+ mpi-inv.c \
+ mpi-mul.c \
+ mpi-pow.c \
+ mpi-scan.c \
+ mpicoder.c \
+ mpih-add.c \
+ mpih-cmp.c \
+ mpih-div.c \
+ mpih-mul.c \
+ mpih-shift.c \
+ mpih-sub.c \
+ mpih-mul1.S \
+ mpih-mul2.S \
+ mpih-add1.S \
+ mpih-mul3.S \
+ mpih-sub1.S \
+ mpih-shift.S \
+ mpih-add.S \
mpiutil.c