summaryrefslogtreecommitdiff
path: root/mpi/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2002-09-18 14:33:03 +0000
committerWerner Koch <wk@gnupg.org>2002-09-18 14:33:03 +0000
commit8726b7f967e764f6d45d2c36b1ea3ea759545da2 (patch)
tree103dd6bf16bdb89dfd1be100e210fd546a7cee05 /mpi/Makefile.am
parent0287345bb38226de6ac0e9744b28f93713b2ce21 (diff)
downloadlibgcrypt-8726b7f967e764f6d45d2c36b1ea3ea759545da2.tar.gz
* Makefile.am (.S.lo): Pass -DPIC. i386, PPC and Sparc code
require it. It worked for me because I am using the i586 code.
Diffstat (limited to 'mpi/Makefile.am')
-rw-r--r--mpi/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/mpi/Makefile.am b/mpi/Makefile.am
index 1a2d5933..d794e432 100644
--- a/mpi/Makefile.am
+++ b/mpi/Makefile.am
@@ -182,6 +182,6 @@ libmpi_la_DEPENDENCIES = @MPI_MOD_LIST_LO@
mv -f _$*.o $@
.S.lo:
- $(CPP) $(INCLUDES) $(DEFS) `test -f '$<' || echo '$(srcdir)/'`$< | grep -v '^#' > __$*.s
+ $(CPP) $(INCLUDES) $(DEFS) -DPIC `test -f '$<' || echo '$(srcdir)/'`$< | grep -v '^#' > __$*.s
$(CCASCOMPILE) -c __$*.s
mv -f __$*.o $@