summaryrefslogtreecommitdiff
path: root/mpi/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2002-05-14 13:11:08 +0000
committerWerner Koch <wk@gnupg.org>2002-05-14 13:11:08 +0000
commit988608c86350d117b164a5f59bde1267bbc5235a (patch)
treeadefecd63a445bbcae54d654fbd2e26207fc3651 /mpi/Makefile.am
parent023396ea3ee6b633c4babfbf7aef0f26f591d48c (diff)
downloadlibgcrypt-988608c86350d117b164a5f59bde1267bbc5235a.tar.gz
Change the license to the LGPL.
Diffstat (limited to 'mpi/Makefile.am')
-rw-r--r--mpi/Makefile.am50
1 files changed, 40 insertions, 10 deletions
diff --git a/mpi/Makefile.am b/mpi/Makefile.am
index b168f0d0..b1f31131 100644
--- a/mpi/Makefile.am
+++ b/mpi/Makefile.am
@@ -1,4 +1,21 @@
## Process this file with automake to produce Makefile.in
+# Copyright (C) 1992, 1999, 2000, 2002 Free Software Foundation, Inc.
+#
+# This file is part of Libgcrypt.
+#
+# Libgcrypt is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of
+# the License, or (at your option) any later version.
+#
+# Libgcrypt is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
INCLUDES = -I$(top_srcdir)/src
CFLAGS = @CFLAGS@ @MPI_OPT_FLAGS@
@@ -35,25 +52,38 @@ libmpi_la_SOURCES = longlong.h \
mpih-mul.c \
mpiutil.c
+EXTRA_libmpi_la_SOURCES = \
+ mpih-mul1.S \
+ mpih-mul2.S \
+ mpih-mul3.S \
+ mpih-add1.S \
+ mpih-sub1.S \
+ mpih-lshift.S \
+ mpih-rshift.S \
+ udiv-qrnnd.S \
+ udiv-w-sdiv.c \
+ udiv.S
+
# Note this objects are actually links, the sourcefiles are
# distributed by special code in dist-hook
-common_asm_objects = mpih-mul1.lo \
- mpih-mul2.lo \
- mpih-mul3.lo \
- mpih-add1.lo \
- mpih-sub1.lo \
- mpih-lshift.lo \
- mpih-rshift.lo
+common_asm_objects = \
+ mpih-mul1.lo \
+ mpih-mul2.lo \
+ mpih-mul3.lo \
+ mpih-add1.lo \
+ mpih-sub1.lo \
+ mpih-lshift.lo \
+ mpih-rshift.lo
libmpi_la_DEPENDENCIES = $(common_asm_objects) @MPI_EXTRA_ASM_OBJS@
libmpi_la_LIBADD = $(common_asm_objects) @MPI_EXTRA_ASM_OBJS@
# cancel the default rules used by libtool which do not really
# work and add one to cpp .S files
-.S.o:
-
-.S.lo:
+#.S.o:
+#
+#.S.lo:
.S.s:
$(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' >$*.s