summaryrefslogtreecommitdiff
path: root/mpi/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2006-12-18 19:02:48 +0000
committerWerner Koch <wk@gnupg.org>2006-12-18 19:02:48 +0000
commitd074ccec673b8c0460ad53a9bb5235ec8d081736 (patch)
treeb3c4248daae41c9b2b102bd4bdd2c61ed9834459 /mpi/Makefile.am
parent37ba2efc88d5c719f430fee44165e729145df7ee (diff)
downloadlibgcrypt-d074ccec673b8c0460ad53a9bb5235ec8d081736.tar.gz
* rndlinux.c (set_cloexec_flag): New.
(open_device): Set close-on-exit flags. Suggested by Max Kellermann. Fixes Debian#403613. Cleaned up last Makefile changes.
Diffstat (limited to 'mpi/Makefile.am')
-rw-r--r--mpi/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/mpi/Makefile.am b/mpi/Makefile.am
index 4a1c27fb..b6213341 100644
--- a/mpi/Makefile.am
+++ b/mpi/Makefile.am
@@ -21,10 +21,15 @@
# I was not able to build it with 64Megs - 1.6 fixes this.
# not anymore required: AUTOMAKE_OPTIONS = 1.6
-INCLUDES = -I$(top_srcdir)/src
-ASFLAGS = @MPI_SFLAGS@
+# Need to include ../src in addition to top_srcdir because gcrypt.h is
+# a built header.
+AM_CPPFLAGS = -I../src -I$(top_srcdir)/src
+AM_CFLAGS = $(GPG_ERROR_CFLAGS)
+
+AM_ASFLAGS = $(MPI_SFLAGS)
AM_CCASFLAGS = $(NOEXECSTACK_FLAGS)
+
# We don't have .S sources listed, so automake does not autocreate these
CCASCOMPILE = $(CCAS) $(AM_CCASFLAGS) $(CCASFLAGS)
LTCCASCOMPILE = $(LIBTOOL) --mode=compile $(CCAS) $(AM_CCASFLAGS) $(CCASFLAGS)
@@ -151,7 +156,6 @@ CLEANFILES = _*.s __*.s
noinst_LTLIBRARIES = libmpi.la
-AM_CFLAGS = -I$(top_builddir)/src @GPG_ERROR_CFLAGS@
libmpi_la_LDFLAGS =
libmpi_la_SOURCES = longlong.h \
mpi-add.c \
@@ -182,7 +186,9 @@ libmpi_la_DEPENDENCIES = @MPI_MOD_LIST_LO@
SUFFIXES = .S .o .obj .lo
.S.o:
- $(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' > $*.s
+ $(CPP) $(INCLUDES) $(AM_CPPFLAGS) $(DEFS) \
+ `test -f '$<' || echo '$(srcdir)/'`$< \
+ | grep -v '^#' > $*.s
$(CCASCOMPILE) -c `test -f '$*.s' || echo '$(srcdir)/'`$*.s
rm $*.s
@@ -190,6 +196,8 @@ SUFFIXES = .S .o .obj .lo
$(CCASCOMPILE) -c `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi`
.S.lo:
- $(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' > $*.s
+ $(CPP) $(INCLUDES) $(AM_CPPFLAGS) $(DEFS) \
+ `test -f '$<' || echo '$(srcdir)/'`$< \
+ | grep -v '^#' > $*.s
$(LTCCASCOMPILE) -c -o $@ `test -f '$*.s' || echo '$(srcdir)/'`$*.s
rm $*.s