summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2013-02-20 20:44:19 +0100
committerWerner Koch <wk@gnupg.org>2013-02-20 20:44:19 +0100
commit70dcac663de06b012417015c175973d64e6980df (patch)
tree449eb6e7d571382fd5e3ebccb70d4b8824d41f98 /src/Makefile.am
parentfb48ebf7081400a24ee48f8a9894a361e8834b6e (diff)
downloadlibgcrypt-70dcac663de06b012417015c175973d64e6980df.tar.gz
Fix building of hwf-x86.c
* src/Makefile.am (AM_CFLAGS): Set to GPG_ERROR_CFLAGS (AM_CCASFLAGS): Set NOEXECSTACK_FLAGS. -- Without that fix we might have used a different gcrypt.h version if we explicitly requested a newer one. Note that dynamically added modules use different rules than the static ones (.c.lo: vs. .c.la:). AM_CCASFLAGS might not be needed right now but may be useful in the future.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cdfe0c6d..9e7dcd5f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,6 +44,8 @@ arch_gpg_error_cflags =
arch_gpg_error_libs =
endif
+AM_CFLAGS = $(GPG_ERROR_CFLAGS)
+AM_CCASFLAGS = $(NOEXECSTACK_FLAGS)
if HAVE_LD_VERSION_SCRIPT
libgcrypt_version_script_cmd = -Wl,--version-script=$(srcdir)/libgcrypt.vers