summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2013-12-22 17:13:45 +0400
committerWerner Koch <wk@gnupg.org>2014-03-04 11:08:03 +0100
commit2b5403c408dfbd71be24c7635f5fa0b61ab4c9bb (patch)
tree7b66b96a84cd21a4a9e8cb279e5db2f79eb3e5f5 /tests/Makefile.am
parentea8d597726305274214224757b32730644e12bd8 (diff)
downloadlibgcrypt-2b5403c408dfbd71be24c7635f5fa0b61ab4c9bb.tar.gz
Add an utility to calculate hashes over a set of files
* tests/gchash.c: New. -- An utility like rhash that has the ability to calculate different hashes over a set of files it usefull. Add gchash utility to calculate hashes supported by libgcrypt. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4cf7a449..9f8839ae 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -51,7 +51,8 @@ standard_ldadd = \
../compat/libcompat.la
EXTRA_PROGRAMS = testapi pkbench
-noinst_PROGRAMS = $(tests_bin) $(tests_bin_last) fipsdrv rsacvt genhashdata
+noinst_PROGRAMS = $(tests_bin) $(tests_bin_last) fipsdrv rsacvt genhashdata \
+ gchash
noinst_HEADERS = t-common.h
EXTRA_DIST = README rsa-16k.key cavs_tests.sh cavs_driver.pl \