summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2011-03-09 17:47:44 +0100
committerWerner Koch <wk@gnupg.org>2011-03-09 17:47:44 +0100
commit9730275d294b4d9cbbb2453541f001c95f5f31a3 (patch)
tree96175205d2fd2670586b0a024d710cbc1796e51a /tests/Makefile.am
parentbf823c5acb713488771c9000242b36ab13649da4 (diff)
downloadlibgcrypt-9730275d294b4d9cbbb2453541f001c95f5f31a3.tar.gz
New function gcry_kdf_derive
This allows us to factor the S2k code from gpg and gpg-agent out to libgcrypt. Created a bunch of test vectors using a hacked gpg 1.4. The function also implements PBKDF2; tested against the RFC-6070 test vectors.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index bf26f680..c34bb96f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,7 +20,7 @@
TESTS = version t-mpi-bit prime register ac ac-schemes ac-data basic \
mpitests tsexp keygen pubkey hmac keygrip fips186-dsa aeswrap \
- curves
+ curves t-kdf
# random.c uses fork() thus a test for W32 does not make any sense.