summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2013-12-16 11:43:22 +0100
committerWerner Koch <wk@gnupg.org>2013-12-16 11:49:05 +0100
commita6b9304a889397ac98e1c2c4ac3e178669d94492 (patch)
tree690e96f72f80471cf49b3cfa864a5124ecdf0623 /tests/Makefile.am
parent5a7ce59396fe56f0d681df314bfbdb5f7732d4b1 (diff)
downloadlibgcrypt-a6b9304a889397ac98e1c2c4ac3e178669d94492.tar.gz
Add configure option --enable-large-data-tests.
* configure.ac: Add option --enable-large-data-tests. * tests/hashtest-256g.in: New. * tests/Makefile.am (EXTRA_DIST): Add hashtest-256g.in. (TESTS): Split up into tests_bin, tests_bin_last, tests_sh, and tests_sh_last. (tests_sh_last): Add hashtest-256g (noinst_PROGRAMS): Add only tests_bin and tests_bin_last. (bench-slope.log, hashtest-256g.log): New rules to enforce serial run. Signed-off-by: Werner Koch <wk@gnupg.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am21
1 files changed, 16 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3fb9fd62..f5b5b9fb 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,13 +18,24 @@
## Process this file with automake to produce Makefile.in
-TESTS = version mpitests tsexp t-convert \
+tests_bin = \
+ version mpitests tsexp t-convert \
t-mpi-bit t-mpi-point curves \
prime basic keygen pubkey hmac hashtest t-kdf keygrip \
fips186-dsa aeswrap pkcs1v2 random dsa-rfc6979 t-ed25519
-# The last tests to run.
-TESTS += benchmark bench-slope
+tests_bin_last = benchmark bench-slope
+
+tests_sh =
+
+tests_sh_last = hashtest-256g
+
+TESTS = $(tests_bin) $(tests_sh) $(tests_bin_last) $(tests_sh_last)
+
+# Force sequential run of some tests.
+bench-slope.log: benchmark.log
+hashtest-256g.log: bench-slope.log
+
TESTS_ENVIRONMENT = GCRYPT_IN_REGRESSION_TEST=1
@@ -37,8 +48,8 @@ AM_CFLAGS = $(GPG_ERROR_CFLAGS)
LDADD = ../src/libgcrypt.la $(DL_LIBS) ../compat/libcompat.la $(GPG_ERROR_LIBS)
EXTRA_PROGRAMS = testapi pkbench
-noinst_PROGRAMS = $(TESTS) fipsdrv rsacvt genhashdata
+noinst_PROGRAMS = $(tests_bin) $(tests_bin_last) fipsdrv rsacvt genhashdata
EXTRA_DIST = README rsa-16k.key cavs_tests.sh cavs_driver.pl \
pkcs1v2-oaep.h pkcs1v2-pss.h pkcs1v2-v15c.h pkcs1v2-v15s.h \
- t-ed25519.inp stopwatch.h
+ t-ed25519.inp stopwatch.h hashtest-256g.in