summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2014-01-24 15:02:15 +0400
committerWerner Koch <wk@gnupg.org>2014-01-24 16:05:20 +0100
commitbf34bfa5c458ee5ece91f25e3b4194d768498ab6 (patch)
tree4f7ce45fcfa24f3ea4c6ba109d871ffc24a61d25 /tests/Makefile.am
parentff91ec934ed52294cddcd7dcfacc04721a0487bf (diff)
downloadlibgcrypt-bf34bfa5c458ee5ece91f25e3b4194d768498ab6.tar.gz
tests: Pass -no-install to libtool
* tests/Makefile.am: add AM_LDFLAGS = -no-install -- There is little point building tests with support for installation. Passing -no-install stops libtool from building wrapper scripts, thus allowing direct gdb/valgrind invocation on programs in tests/ subdirectory. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f0a46338..ac5ab707 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -44,6 +44,7 @@ TESTS_ENVIRONMENT = GCRYPT_IN_REGRESSION_TEST=1
# a built header.
AM_CPPFLAGS = -I../src -I$(top_srcdir)/src
AM_CFLAGS = $(GPG_ERROR_CFLAGS)
+AM_LDFLAGS = -no-install
default_ldadd = \
../src/libgcrypt.la $(DL_LIBS) \