summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ab160c3c..e416ceb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,6 +197,8 @@ LIBGCRYPT_THREAD_MODULES=""
print_egd_notice=no
have_w32_system=no
have_w32ce_system=no
+have_pthread=no
+
# Setup some stuff depending on host.
case "${host}" in
@@ -631,6 +633,14 @@ fi
AC_SUBST(PTH_CFLAGS)
AC_SUBST(PTH_LIBS)
+#
+# Check whether pthreads is available
+#
+AC_CHECK_LIB(pthread,pthread_create,have_pthread=yes)
+if test "$have_pthread" = yes; then
+ AC_DEFINE(HAVE_PTHREAD, ,[Define if we have pthread.])
+fi
+
# Solaris needs -lsocket and -lnsl. Unisys system includes
# gethostbyname in libsocket but needs libnsl for socket.