summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4d16fc69..62544533 100644
--- a/configure.ac
+++ b/configure.ac
@@ -729,9 +729,11 @@ AC_SUBST(PTH_LIBS)
#
# Check whether pthreads is available
#
-AC_CHECK_LIB(pthread,pthread_create,have_pthread=yes)
-if test "$have_pthread" = yes; then
- AC_DEFINE(HAVE_PTHREAD, 1 ,[Define if we have pthread.])
+if test "$have_w32_system" != yes; then
+ AC_CHECK_LIB(pthread,pthread_create,have_pthread=yes)
+ if test "$have_pthread" = yes; then
+ AC_DEFINE(HAVE_PTHREAD, 1 ,[Define if we have pthread.])
+ fi
fi