summaryrefslogtreecommitdiff
path: root/mpi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mpi/Makefile.am')
-rw-r--r--mpi/Makefile.am45
1 files changed, 27 insertions, 18 deletions
diff --git a/mpi/Makefile.am b/mpi/Makefile.am
index 5edd90c2..353ab23a 100644
--- a/mpi/Makefile.am
+++ b/mpi/Makefile.am
@@ -1,27 +1,36 @@
## Process this file with automake to produce Makefile.in
INCLUDES = -I$(top_srcdir)/include
+CFLAGS += -O2
noinst_LIBRARIES = mpi
-mpi_SOURCES = longlong.h \
- mpi-add.c \
- mpi-bit.c \
- mpi-cmp.c \
- mpi-div.c \
- mpi-gcd.c \
- mpi-internal.h \
- mpi-inv.c \
- mpi-mul.c \
- mpi-pow.c \
- mpi-scan.c \
- mpicoder.c \
- mpihelp-add.c \
- mpihelp-cmp.c \
- mpihelp-div.c \
- mpihelp-mul.c \
- mpihelp-shift.c \
- mpihelp-sub.c \
+mpi_SOURCES = longlong.h \
+ mpi-add.c \
+ mpi-bit.c \
+ mpi-cmp.c \
+ mpi-div.c \
+ mpi-gcd.c \
+ mpi-internal.h \
+ mpi-inline.h \
+ mpi-inv.c \
+ mpi-mul.c \
+ mpi-pow.c \
+ mpi-scan.c \
+ mpicoder.c \
+ mpih-add.c \
+ mpih-cmp.c \
+ mpih-div.c \
+ mpih-mul.c \
+ mpih-shift.c \
+ mpih-sub.c \
+ mpih-mul1.S \
+ mpih-mul2.S \
+ mpih-add1.S \
+ mpih-mul3.S \
+ mpih-sub1.S \
+ mpih-shift.S \
+ mpih-add.S \
mpiutil.c