summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2016-09-16 13:56:47 +0200
committerPeter Wu <peter@lekensteyn.nl>2016-09-17 09:11:49 +0000
commit05ae6a7560a8f39daac073d2094fdcde6975a4ec (patch)
tree2f0a0da0ef72fcb3cd9a49b63e5bc609bd7415e9 /CMakeLists.txt
parent41567191d8c19d2b27571f9c1713fa1f9d6bd11a (diff)
downloadwireshark-05ae6a7560a8f39daac073d2094fdcde6975a4ec.tar.gz
Remove -Wdeclaration-after-statement
This is a C99 feature which we can use now. Change-Id: I84a63d6bf282b79c9f0da0543b3b4f5a0cf0c81a Reviewed-on: https://code.wireshark.org/review/17733 Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d3ff5e9de..3ff8415106 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -419,7 +419,6 @@ else()
set(C_WARN_FLAGS
# The following are C only, not C++
-Wc++-compat
- -Wdeclaration-after-statement
-Wshadow
-Wno-pointer-sign
-Wold-style-definition