summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2014-08-20 22:29:33 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2014-08-22 22:04:33 +0000
commit06565a742411b3d5307cab70a85d5f196073eb90 (patch)
tree747a4255c35e0344d7661ec7c52d490b715180ea /CMakeLists.txt
parent863b6646d6995b7f0a7c70aad845c7bb3f00dbc7 (diff)
downloadwireshark-06565a742411b3d5307cab70a85d5f196073eb90.tar.gz
Add WinSparkle to the CMake build to bring it into line with
the nmake build Change-Id: I944d0fe15b396cad4d0054b6fc359acb42ae3c9c Reviewed-on: https://code.wireshark.org/review/3755 Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 154f0ae169..299ddffa20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -595,6 +595,11 @@ if(ENABLE_CAP)
set(PACKAGELIST ${PACKAGELIST} CAP SETCAP)
endif()
+# Windows version updates
+if(ENABLE_WINSPARKLE)
+ set(PACKAGELIST ${PACKAGELIST} WINSPARKLE)
+endif()
+
set(PACKAGELIST ${PACKAGELIST} YAPP)
set(PACKAGELIST ${PACKAGELIST} POD)
@@ -694,6 +699,11 @@ endif()
if(HAVE_LIBSBC)
set(HAVE_SBC 1)
endif()
+
+if (HAVE_LIBWINSPARKLE)
+ set(HAVE_SOFTWARE_UPDATE 1)
+endif()
+
# No matter which version of GTK is present
if(GTK2_FOUND OR GTK3_FOUND)
set(GTK_FOUND ON)
@@ -1063,6 +1073,7 @@ set(LIBEPAN_LIBS
${ZLIB_LIBRARIES}
${M_LIBRARIES}
${SBC_LIBRARIES}
+ ${WINSPARKLE_LIBRARIES}
)
if( (BUILD_wireshark AND GTK_FOUND) OR (BUILD_qtshark AND QT_FOUND) )