summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-07-14 12:32:48 -0700
committerGerald Combs <gerald@wireshark.org>2016-07-14 19:34:39 +0000
commit06ba81b4f1acb371f7cbc2e351f6769a7d2627db (patch)
tree35df4bf021974024a28a2fa6bba610ddeddc88b0 /CMakeLists.txt
parent36e8a6c3ee6127bb4b92d29ed558613be59c6d5d (diff)
downloadwireshark-06ba81b4f1acb371f7cbc2e351f6769a7d2627db.tar.gz
Build 2.1.1, second try.
The buildbots that create packages run `perl make-version.pl --set-release` at the beginning of each build. This in turn sets the extra version information for our generated packages to "-g<abbreviated hash>" for development builds, or "" (an empty string) for release builds. Hardcoding the extra version information to "-git" in CMakeLists.txt and configure.ac means we end up with wireshark-2.1.0-git.tar.bz2, Wireshark-win64-2.1.0-git.exe, etc. for release builds. Set them back to empty strings. Change-Id: Icdfb248d25ad4adbc9abe0bd938e410590e42828 Reviewed-on: https://code.wireshark.org/review/16439 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9f37eb6433..34fc9382db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -180,7 +180,7 @@ set(PROJECT_MAJOR_VERSION 2)
set(PROJECT_MINOR_VERSION 1)
set(PROJECT_PATCH_VERSION 1)
set(PROJECT_BUILD_VERSION ${GIT_REVISION})
-set(PROJECT_VERSION_EXTENSION "-git")
+set(PROJECT_VERSION_EXTENSION "")
if(DEFINED ENV{WIRESHARK_VERSION_EXTRA})
set(PROJECT_VERSION_EXTENSION "$ENV{WIRESHARK_VERSION_EXTRA}")