summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2015-04-26 12:26:05 -0400
committerAnders Broman <a.broman58@gmail.com>2015-04-28 07:37:14 +0000
commit0b368ea23ff86d1895f6c8572a1014490b574d31 (patch)
tree51cc1bd8b05b309d2017659ab8b3cffa188a5309 /CMakeLists.txt
parent8c996a2736504aa727899213597805574c09981a (diff)
downloadwireshark-0b368ea23ff86d1895f6c8572a1014490b574d31.tar.gz
Add service_response_time_table for TShark srt stats.
This is a "refactoring part 1" of the srt stats. This first step is using the service_response_time_table for all (possible) TShark srt stats. Next step will be combining the GTK and TShark service_response_time_table, so there is more code reuse and the "shared structure names" between GTK and TShark service_response_time_table won't seem as bad. Maybe it can even go one step farther and handle a dynamic number of columns so this refactoring can apply to all srt stats. Change-Id: Ief28e7e55f7dbbf4f2d9bb6f1a1592b87b866137 Reviewed-on: https://code.wireshark.org/review/8210 Reviewed-by: Michael Mann <mmann78@netscape.net> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 42bf9f9cc9..ac9208c70e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1116,6 +1116,7 @@ if(ENABLE_EXTCAP)
endif()
set(TSHARK_TAP_SRC
+ ui/cli/cli_service_response_time_table.c
ui/cli/tap-afpstat.c
ui/cli/tap-ansi_astat.c
ui/cli/tap-bootpstat.c