summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-06-01 02:20:12 +0000
committerGuy Harris <guy@alum.mit.edu>2013-06-01 02:20:12 +0000
commit15a0d1f945958ab4f56c5e886c71827886b6c12e (patch)
tree46d593e4de2c84babe2a372782ff34b3041f41ad /CMakeLists.txt
parent00ea06430afecea4263fe27e30f98332a1c2b97f (diff)
downloadwireshark-15a0d1f945958ab4f56c5e886c71827886b6c12e.tar.gz
Update various warning-option lists to match what the configure script
adds by default. svn path=/trunk/; revision=49670
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 14 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 70a4cf3191..b1b0316005 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -126,6 +126,17 @@ set(WIRESHARK_C_FLAGS
-Warray-bounds
-Wcast-align
-Wformat-security
+ -Wshorten-64-to-32
+ -Wvla
+ -Waddress
+ -Warray-bounds
+ -Wattributes
+ -Wdiv-by-zero
+ -Wignored-qualifiers
+ -Wpragmas
+ -Wno-overlength-strings
+ -Wwrite-strings
+ -Wno-long-long
)
if (NOT APPLE)
set(WIRESHARK_C_FLAGS ${WIRESHARK_C_FLAGS} -fexcess-precision=fast)
@@ -136,46 +147,30 @@ set(WIRESHARK_C_ONLY_FLAGS
-Wc++-compat
-Wdeclaration-after-statement
-Wlogical-op
+ -Wshadow
-Wno-pointer-sign
-Wold-style-definition
-Wshadow
+ -Wstrict-prototypes
+ -Wjump-misses-init
)
set(WIRESHARK_EXTRA_C_FLAGS
-pedantic
-Woverflow
- -Wno-overlength-strings
-fstrict-overflow -Wstrict-overflow=4
-Wunreachable-code
-Wunsafe-loop-optimizations
- -Wno-long-long
-Wcast-qual
- -Waddress
- -Warray-bounds
- -Wattributes
- -Wdiv-by-zero
-Wformat-security
- -Wignored-qualifiers
- -Wpragmas
-Wredundant-decls
- -Wvla
- # packet-ncp2222.inc prevents this from going into all warnings
- -Wwrite-strings
# All the registration functions block these for now.
-Wmissing-declarations
- # Problem with packet-afs.c
- -Wshadow
- # More cleanup needed for this on LP64
- -Wshorten-64-to-32
-
)
set(WIRESHARK_EXTRA_C_ONLY_FLAGS
# The following are C only, not C++
-Wbad-function-cast
- -Wjump-misses-init
- # GLib blocks this for now.
- -Wstrict-prototypes
# All the registration functions block these for now.
-Wmissing-prototypes
)