summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBalint Reczey <balint@balintreczey.hu>2013-03-02 22:27:40 +0000
committerBalint Reczey <balint@balintreczey.hu>2013-03-02 22:27:40 +0000
commit1eb5e1d73970baa2bf0dd603e5da02c9b6a2e617 (patch)
tree08fd014234f05f1e351e9a632edd846e55bf1d66 /CMakeLists.txt
parentfc9156a8a0951e645cca59a2173a8101eca0dba8 (diff)
downloadwireshark-1eb5e1d73970baa2bf0dd603e5da02c9b6a2e617.tar.gz
Revert "Make Solaris Studio hide internal shared library symbols by default"
This reverts commit r48020. svn path=/trunk/; revision=48022
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3cdce2ad81..d00a66be27 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -218,13 +218,8 @@ check_c_compiler_flag(-fvisibility=hidden FVHIDDEN)
if((FVHIDDEN))
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden")
else() # TODO add alternate compiler flags for hiding symbols
- check_c_compiler_flag(-xldscope=hidden FVHIDDEN)
- if((FVHIDDEN))
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden")
- else()
- message(WARNING "Hiding shared library symbols is not supported by the compiler."
+ message(WARNING "Hiding shared library symbols is not supported by the compiler."
" All shared library symbols will be exported.")
- endif()
endif()
if(NOT DISABLE_WERROR AND NOT ENABLE_EXTRA_GCC_CHECKS)