summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2015-11-21 23:48:27 +0000
committerMichael Mann <mmann78@netscape.net>2015-12-12 16:21:19 +0000
commit2aab706c5a5d61c61bbff6e9e36a57afc4ef3be8 (patch)
tree311fa08b5404d23cc4cfa644c87f84ab7422b61f /CMakeLists.txt
parent95142cf09d4789c9c68108b56f5fbe467108494f (diff)
downloadwireshark-2aab706c5a5d61c61bbff6e9e36a57afc4ef3be8.tar.gz
Remove -Wwrite-strings compiler flag
The "-Wwrite-strings" flag produces nuisance warnings. These warnings are not useful, they're impossible to fix in a sane way and therefore are being handled with casts of static strings to (char *). This just moves the warning to [-Wcast-qual] and a compiler pragma is in turn required (and used) to squelch that warning. Remove the Wwrite-strings warning. Let that responsibility fall on the programmer (as is done by casting). Change-Id: I5a44dfd9decd6d80797a521a3373593074962fb5 Reviewed-on: https://code.wireshark.org/review/12162 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f3b007698..8b53e7cfc8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -359,7 +359,6 @@ else()
-Wignored-qualifiers
-Wpragmas
-Wno-overlength-strings
- -Wwrite-strings
-Wno-long-long
-Wheader-guard
-Wunused-const-variable