summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2011-08-05 00:25:02 +0000
committerGerald Combs <gerald@wireshark.org>2011-08-05 00:25:02 +0000
commit3d2c4f6182e366aa4b797ed0085dd3f012550a0b (patch)
tree569f1348869aec0bc2c6fc2d73b07a3f48209ee1 /CMakeLists.txt
parent5c064e144af304f9211877c4e9aef7a93792e764 (diff)
downloadwireshark-3d2c4f6182e366aa4b797ed0085dd3f012550a0b.tar.gz
Use GLIB2_LDFLAGS instead of GLIB2_LIBRARIES for wsutil, since it
includes the path to the libraries. Add gthread to wireshark_LIBS if threads are enabled. svn path=/trunk/; revision=38345
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f1f9cf0e4..5a1a585d71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,6 +243,9 @@ if(BUILD_wireshark)
set(GTK2_FIND_VERSION 2.12)
set(GTK2_DEBUG false)
endif()
+ if(ENABLE_THREADS)
+ set(PACKAGELIST ${PACKAGELIST} GTHREAD2)
+ endif()
endif()
if(BUILD_dumpcap)
@@ -667,6 +670,9 @@ if(BUILD_wireshark AND GTK_FOUND)
${APPLE_CORE_SERVICES_LIBRARY}
${APPLE_COCOA_LIBRARY}
)
+ if(ENABLE_THREADS)
+ set(wireshark_LIBS ${wireshark_LIBS} ${GTHREAD2_LIBRARIES})
+ endif()
set(wireshark_FILES
airpcap_loader.c
alert_box.c