summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-04-19 08:03:08 +0100
committerJoão Valverde <j@v6e.pt>2016-04-21 18:59:56 +0000
commit3db13a7fc9f08fdb238f06e73a42b39396fee84c (patch)
tree13962d67e01b8d0f15aed5e6216ae584c23bd991 /CMakeLists.txt
parent7c6e859ccf210a45e1cc0f6da17692845e6b5a23 (diff)
downloadwireshark-3db13a7fc9f08fdb238f06e73a42b39396fee84c.tar.gz
Link version code statically again
This allows keeping the code-sharing with the static linking. This "fixes" a hypothetical ABI mismatch with wsutil and avoids pulling more external dependencies to wsutil than strictly necessary. A nice side-effect is that libwsutil no longer depends on version.h. Follow up to f95976eefcbeb5d24df383c29d29ef888b503945. Change-Id: I8f0d6a557ab3f7ce6f0e2c269124c89f29d6ad23 Reviewed-on: https://code.wireshark.org/review/15002 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a4800ae9d..fdf7bb3b16 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1257,6 +1257,7 @@ set(SHARK_COMMON_SRC
cfile.c
frame_tvbuff.c
sync_pipe_write.c
+ ws_version_info.c
)
# sources for external capture interfaces
@@ -2135,6 +2136,7 @@ if(BUILD_randpkt)
)
set(randpkt_FILES
randpkt.c
+ ws_version_info.c
)
add_executable(randpkt ${randpkt_FILES})
set_extra_executable_properties(randpkt "Executables")
@@ -2151,6 +2153,7 @@ if(BUILD_text2pcap)
)
set(text2pcap_CLEAN_FILES
text2pcap.c
+ ws_version_info.c
)
set(text2pcap_FILES
${text2pcap_CLEAN_FILES}
@@ -2173,6 +2176,7 @@ if(BUILD_mergecap)
)
set(mergecap_FILES
mergecap.c
+ ws_version_info.c
${CMAKE_BINARY_DIR}/image/mergecap.rc
)
add_executable(mergecap ${mergecap_FILES})
@@ -2189,6 +2193,7 @@ if(BUILD_reordercap)
)
set(reordercap_FILES
reordercap.c
+ ws_version_info.c
${CMAKE_BINARY_DIR}/image/reordercap.rc
)
add_executable(reordercap ${reordercap_FILES})
@@ -2207,6 +2212,7 @@ if(BUILD_capinfos)
)
set(capinfos_FILES
capinfos.c
+ ws_version_info.c
${CMAKE_BINARY_DIR}/image/capinfos.rc
)
add_executable(capinfos ${capinfos_FILES})
@@ -2224,6 +2230,7 @@ if(BUILD_captype)
)
set(captype_FILES
captype.c
+ ws_version_info.c
${CMAKE_BINARY_DIR}/image/captype.rc
)
add_executable(captype ${captype_FILES})
@@ -2240,6 +2247,7 @@ if(BUILD_editcap)
)
set(editcap_FILES
editcap.c
+ ws_version_info.c
${CMAKE_BINARY_DIR}/image/editcap.rc
)
add_executable(editcap ${editcap_FILES})
@@ -2270,6 +2278,7 @@ if(BUILD_dumpcap AND PCAP_FOUND)
filter_files.c
ringbuffer.c
sync_pipe_write.c
+ ws_version_info.c
${CMAKE_BINARY_DIR}/image/dumpcap.rc
)
add_executable(dumpcap ${dumpcap_FILES})