summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2013-08-01 23:40:06 +0000
committerGerald Combs <gerald@wireshark.org>2013-08-01 23:40:06 +0000
commit45589bf41de51ffdbdcd9b5b84d4b7b611e8925a (patch)
tree399fad4cd46cabd009c7ee5cd58872a6c435a911 /CMakeLists.txt
parent2df54da6e2b70777154d38ce3923093568358285 (diff)
downloadwireshark-45589bf41de51ffdbdcd9b5b84d4b7b611e8925a.tar.gz
TShark links with libui so we should always build it.
svn path=/trunk/; revision=51101
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bbd4c78a68..6521cbe9aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -528,6 +528,7 @@ add_subdirectory( asn1 EXCLUDE_FROM_ALL )
add_subdirectory( codecs )
add_subdirectory( epan )
add_subdirectory( tools/lemon )
+add_subdirectory( ui )
add_subdirectory( wiretap )
add_subdirectory( wsutil )
@@ -537,10 +538,6 @@ if(ENABLE_ECHLD)
add_subdirectory( echld )
endif()
-if((BUILD_wireshark AND GTK_FOUND) OR (BUILD_qtshark AND QT_FOUND))
- add_subdirectory( ui )
-endif()
-
if(BUILD_wireshark AND GTK_FOUND)
add_subdirectory( ui/gtk )
endif()