summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-06-28 10:35:27 -0700
committerGerald Combs <gerald@wireshark.org>2016-06-29 18:11:59 +0000
commit46561910f4372ac9fc591bb225298bee7e2879b8 (patch)
treea4105d4f2bc5ba5c9f05679c84d4c04fcfb2fe42 /CMakeLists.txt
parentceae9e4d1fff4500b285dba021c3f239ff87779e (diff)
downloadwireshark-46561910f4372ac9fc591bb225298bee7e2879b8.tar.gz
CMake: Update the macOS wrapper script behavior.
CMake on macOS creates a convenience wrapper (run/wireshark) that runs run/Wireshark.app/Contents/MacOS/Wireshark. Have it run the executable using "exec" instead of opening the bundle using "open" so that Wireshark runs in the foreground. Change-Id: I295ce0681da75678e5e01781e9c8fb58e2236fc9 Reviewed-on: https://code.wireshark.org/review/16196 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8c7bd5a29..c79ee445fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1844,7 +1844,8 @@ if(BUILD_wireshark AND QT_FOUND)
# convenience but makes debugging more difficult.
file(REMOVE ${CMAKE_BINARY_DIR}/run/wireshark)
file(WRITE ${CMAKE_BINARY_DIR}/run/wireshark "#!/bin/sh\n")
- file(APPEND ${CMAKE_BINARY_DIR}/run/wireshark "open ${CMAKE_BINARY_DIR}/run/Wireshark.app --args \"\$\@\"\n")
+ file(APPEND ${CMAKE_BINARY_DIR}/run/wireshark "# Generated by ${CMAKE_CURRENT_LIST_FILE}\n")
+ file(APPEND ${CMAKE_BINARY_DIR}/run/wireshark "exec ${CMAKE_BINARY_DIR}/run/Wireshark.app/Contents/MacOS/Wireshark \"\$\@\"\n")
execute_process(COMMAND chmod a+x ${CMAKE_BINARY_DIR}/run/wireshark)
endif()