summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2016-10-28 11:49:06 +0200
committerJörg Mayer <jmayer@loplof.de>2016-10-29 06:02:37 +0000
commit4728bc201bddc34a7834aedf65704c7aa1c9daf1 (patch)
tree454051d34989115d942c9c22383e9ca84f172028 /CMakeLists.txt
parent183856f7240288f67898b2a2110b7f51a0c0f2b6 (diff)
downloadwireshark-4728bc201bddc34a7834aedf65704c7aa1c9daf1.tar.gz
Instead of supressing the warning of policy 42, set MACOSX_RPATH.
Fixes picking up the system libpcap instead of the one in /usr/local/lib/ Change-Id: I488c8512fc2cde145107062a6e8b7815ad764a3b Reviewed-on: https://code.wireshark.org/review/18545 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 044f43c20c..e9e5df1894 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,10 +67,8 @@ if (POLICY CMP0054)
cmake_policy(SET CMP0054 OLD)
endif()
-# Set old behaviour for MACOSX_RPATH
-if (POLICY CMP0042)
- cmake_policy(SET CMP0042 OLD)
-endif()
+# See https://cmake.org/Wiki/CMake_RPATH_handling
+set(MACOSX_RPATH ON)
# If our target platform is enforced by our generator, set
# WIRESHARK_TARGET_PLATFORM accordingly. Otherwise use