summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBenoît Canet <benoit@scylladb.com>2016-09-26 16:25:11 +0200
committerPascal Quantin <pascal.quantin@gmail.com>2016-10-17 18:28:45 +0000
commit47649d1c7fb6ba48b805e19268a711404eb6908b (patch)
tree603eea5969a564511df482a2d8d6a9525cfea74b /CMakeLists.txt
parent5c42d8a24c863549166bc1d0875e87a07bedf53e (diff)
downloadwireshark-47649d1c7fb6ba48b805e19268a711404eb6908b.tar.gz
cql: add lz4 and snappy decompression
We do not use the STARTUP negotiation since a stream can be captured in its middle but try to decompress if the flag is present and fallback if it fails. Change-Id: Iecbf49a45220b04be7808869c9884548eb1e7694 Signed-off-by: Benoît Canet <benoit@scylladb.com> Reviewed-on: https://code.wireshark.org/review/17952 Reviewed-by: Pascal Quantin <pascal.quantin@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebfe8a1342..68af9a53bb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -830,6 +830,16 @@ if(ENABLE_ZLIB)
set(PACKAGELIST ${PACKAGELIST} ZLIB)
endif()
+# LZ4 compression
+if(ENABLE_LZ4)
+ set(PACKAGELIST ${PACKAGELIST} LZ4)
+endif()
+
+# Snappy compression
+if(ENABLE_SNAPPY)
+ set(PACKAGELIST ${PACKAGELIST} SNAPPY)
+endif()
+
# Embedded Lua interpreter
if(ENABLE_LUA)
set(PACKAGELIST ${PACKAGELIST} LUA)
@@ -975,6 +985,12 @@ if(HAVE_LIBZLIB)
# bug in the Windows setup of GTK[23] which has a faulty zconf.h.
include_directories(BEFORE ${ZLIB_INCLUDE_DIRS})
endif()
+if(HAVE_LIBLZ4)
+ set(HAVE_LZ4 1)
+endif()
+if(SNAPPY_FOUND)
+ set(HAVE_SNAPPY 1)
+endif()
if (Qt5Widgets_FOUND)
#
# Qt5CoreConfigExtras.cmake in Qt 5.5.0 sets -fPIC unconditionally:
@@ -1452,6 +1468,8 @@ set(LIBEPAN_LIBS
${GNUTLS_LIBRARIES}
${SMI_LIBRARIES}
${ZLIB_LIBRARIES}
+ ${LZ4_LIBRARIES}
+ ${SNAPPY_LIBRARIES}
${M_LIBRARIES}
${WINSPARKLE_LIBRARIES}
)