summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-04-07 12:55:42 -0700
committerGerald Combs <gerald@wireshark.org>2015-04-14 19:11:50 +0000
commit495740f801ccb4ce73f517a3a99ba8dacdba744c (patch)
tree9d432f032b7202d80575c0bfeaf3ba2944050db0 /CMakeLists.txt
parent1404605513cedd34070154aa355663b8e4734bc4 (diff)
downloadwireshark-495740f801ccb4ce73f517a3a99ba8dacdba744c.tar.gz
CMake: Initial PortableApps targets.
Add portableapps_app_dir and portableapps_package targets. Change-Id: Ifea3d952eef0e267de6364999d45807236d99102 Reviewed-on: https://code.wireshark.org/review/8025 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 780d1d7ca7..7ac850c136 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2139,6 +2139,16 @@ if (WIN32)
ADD_NSIS_UNINSTALLER_TARGET()
ADD_NSIS_PACKAGE_TARGET()
endif()
+
+ find_package( PortableApps )
+ if (
+ NOT "${PORTABLEAPPS_LAUNCHER_GENERATOR_EXECUTABLE}" STREQUAL "PORTABLEAPPS_LAUNCHER_GENERATOR_EXECUTABLE-NOTFOUND"
+ AND
+ NOT "${PORTABLEAPPS_INSTALLER_EXECUTABLE}" STREQUAL "PORTABLEAPPS_INSTALLER_EXECUTABLE-NOTFOUND"
+ )
+ add_subdirectory( packaging/portableapps EXCLUDE_FROM_ALL )
+ ADD_PORTABLEAPPS_PACKAGE_TARGET()
+ endif()
endif()
if(BUILD_androiddump)