summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPascal Quantin <pascal.quantin@gmail.com>2017-06-10 16:31:52 +0200
committerPascal Quantin <pascal.quantin@gmail.com>2017-06-10 16:32:59 +0000
commit4edc611526fc2aa17a7f5e82ce0147d799d2c508 (patch)
treee12d5f1444563a6264eed1d9309c255105e29f27 /CMakeLists.txt
parent0dc32776d071fdf00754e349a0f9db20119df5df (diff)
downloadwireshark-4edc611526fc2aa17a7f5e82ce0147d799d2c508.tar.gz
Windows: increase minimum CMake version to 3.7
g9f0d22b introduced the use of GREATER_EQUAL operator. Let's update the minimum CMake version accordingly. Change-Id: Ibf619a24f5ee296b547fbc6ba46e13b8a1f3302c Reviewed-on: https://code.wireshark.org/review/22066 Petri-Dish: Pascal Quantin <pascal.quantin@gmail.com> Reviewed-by: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Pascal Quantin <pascal.quantin@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1916c1bfa1..86e4614197 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,10 +37,8 @@ set(PROJECT_VERSION "${PROJECT_MAJOR_VERSION}.${PROJECT_MINOR_VERSION}.${PROJECT
message(STATUS "Generating build using CMake ${CMAKE_VERSION}")
if(WIN32)
- # Needed for proper Qt linking. See
- # http://www.cmake.org/cmake/help/v3.0/policy/CMP0020.html
- # 3.1.3 is the currently supported version
- cmake_minimum_required(VERSION 3.1.3)
+ # Needed for GREATER_EQUAL operator
+ cmake_minimum_required(VERSION 3.7)
else()
cmake_minimum_required(VERSION 2.8.8)
endif()