summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2016-09-30 16:06:15 +0200
committerDario Lombardo <lomato@gmail.com>2016-09-30 20:08:02 +0000
commit534787e402d6aa8b349638f911a2a65b013c6594 (patch)
tree9cfaeb38a16eab0fee86b3b0fb8f9245c7813f7a /CMakeLists.txt
parent53c91974c7e8f77555920e137cab80b5418e992b (diff)
downloadwireshark-534787e402d6aa8b349638f911a2a65b013c6594.tar.gz
cmake: make WERROR_COMMON_FLAGS a normal string
Instead of checking for the boolean "FALSE", just set an empty string. This avoids the need to check for WERROR_COMMON_FLAGS before using it. The transformation is the same for all files, remove "if (WERROR_COMMON_FLAGS)" and "endif()", reindent and add quotes (since we have a string here and not a list). Modelines have been added where missing. Change-Id: I0ab05ae507c51fa77336d49a99a226399cc81b92 Reviewed-on: https://code.wireshark.org/review/17997 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Dario Lombardo <lomato@gmail.com> Tested-by: Dario Lombardo <lomato@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 7 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0530ee359e..988ca8577e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -595,10 +595,11 @@ if(ENABLE_ASAN)
set(CMAKE_CXX_FLAGS "-fsanitize=address ${CMAKE_CXX_FLAGS}")
endif()
+set(WERROR_COMMON_FLAGS "")
+set(NO_ERROR_DEPRECATED_DECLARATIONS_COMPILE_FLAGS "")
if(NOT DISABLE_WERROR AND NOT ENABLE_EXTRA_COMPILER_WARNINGS)
if(CMAKE_C_COMPILER_ID MATCHES "MSVC")
set(WERROR_COMMON_FLAGS "/WX")
- set(NO_ERROR_DEPRECATED_DECLARATIONS_COMPILE_FLAGS)
else()
check_c_compiler_flag(-Werror WERROR)
if (WERROR)
@@ -606,8 +607,6 @@ if(NOT DISABLE_WERROR AND NOT ENABLE_EXTRA_COMPILER_WARNINGS)
set(NO_ERROR_DEPRECATED_DECLARATIONS_COMPILE_FLAGS "-Wno-error=deprecated-declarations")
endif()
endif()
-else()
- set(WERROR_COMMON_FLAGS FALSE)
endif()
#
@@ -2620,13 +2619,11 @@ set(CLEAN_FILES
${udpdump_FILES}
)
-if (WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${CLEAN_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
install(
FILES