summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-06-10 15:26:57 -0700
committerAnders Broman <a.broman58@gmail.com>2016-06-15 20:51:34 +0000
commit561a063feee5b3ea8ac9d7d3254e16ec31bb7646 (patch)
treeeb25557df34a6cdb30949aae3aa14d1688da90b7 /CMakeLists.txt
parentca1c5f540a13676240ac82f26e79b1b6c0bc5a54 (diff)
downloadwireshark-561a063feee5b3ea8ac9d7d3254e16ec31bb7646.tar.gz
Pass "/utf-8" to Visual C++ 2015.
Many projects (Qt[1] and GNOME[2] in particular) either recommend, use, or at least allow for UTF-8 in source and header files. Pass /utf-8 to Visual C++ 2015 so that it will behave itself around UTF-8 and be more like that nice compiler down the street. [1] https://wiki.qt.io/Strings_and_encodings_in_Qt [2] https://bugzilla.gnome.org/show_bug.cgi?id=767218 Change-Id: Ibc90d235742134cb42dd796ba529699bcbbe3ad0 Reviewed-on: https://code.wireshark.org/review/15821 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 006b2aaad2..30cf67033a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -295,8 +295,9 @@ if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
set(LOCAL_CFLAGS ${LOCAL_CFLAGS} "/Zo")
elseif(MSVC14)
# /Zo Enhanced debugging of optimised code
+ # /utf-8 Set Source and Executable character sets to UTF-8
# VS2015(MSVC14): On by default when /Zi or /Z7 used.
- set(LOCAL_CFLAGS ${LOCAL_CFLAGS} "/Zo")
+ set(LOCAL_CFLAGS ${LOCAL_CFLAGS} "/Zo" "/utf-8")
endif()
if(ENABLE_CODE_ANALYSIS)