summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-04-20 13:25:21 -0700
committerGuy Harris <guy@alum.mit.edu>2017-04-20 20:25:59 +0000
commit64ec2b2e5ed590a6f1a3d22c8b24a6e70420d1f9 (patch)
treeaab752fe44790898535c850d89e015b75b569149 /CMakeLists.txt
parent2e6cb9dbab154531b306e472642ff6033f0e341c (diff)
downloadwireshark-64ec2b2e5ed590a6f1a3d22c8b24a6e70420d1f9.tar.gz
Take the error message generation out of the merge_files routines.
Have them just return the information needed for the caller to produce an error message, and have the callers use the new cfile_ routines for reporting errors. This requires that the "write failure alert box" routine take the *input* file name as an argument, so that, on a merge, if the problem is that a record from a given input file can't be written out to the type of output file we're generating, the input file name can be given, along with the record number in that file. Change-Id: If5a5e00539e7e652008a523dec92c0b359a48e71 Reviewed-on: https://code.wireshark.org/review/21257 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0ef9dea85..dc2b9550e8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2407,6 +2407,7 @@ endif()
if(BUILD_mergecap)
set(mergecap_LIBS
+ ui
wiretap
${ZLIB_LIBRARIES}
${CMAKE_DL_LIBS}