summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2017-02-09 15:00:19 +0100
committerPeter Wu <peter@lekensteyn.nl>2017-02-13 18:35:47 +0000
commit6b84ddee83e70aff944da084129624226b7a32fa (patch)
tree7cac052f5b5adb25c301b9974e79a334aa36b13b /CMakeLists.txt
parentb5610a0436f332c664a91b86cb5326f24601bbf1 (diff)
downloadwireshark-6b84ddee83e70aff944da084129624226b7a32fa.tar.gz
Make Libgcrypt a mandatory dependency
Removed all guards for HAVE_LIBGCRYPT, change autotools and CMake to error out if it is not available. Update release notes, developer documentation and README with the new status. Clarify relation with GnuTLS in macosx-setup.sh. Install Libgcrypt via brew script. Motivation for this change is that many dissectors depend on Libgcrypt and having it optional increases the maintenance burden (there have been several compile issues in the past due to the optional status). Furthermore, wsutil has crypto code that can be replaced by Libgcrypt. Change-Id: Idf0021b8c4cd5db70b8766f7dcc2a8b3acbf042f Link: https://www.wireshark.org/lists/wireshark-dev/201702/msg00011.html Reviewed-on: https://code.wireshark.org/review/20030 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Pascal Quantin <pascal.quantin@gmail.com> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 10 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bfa36d8d54..08eb05c31b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -790,11 +790,9 @@ if(ENABLE_SMI)
endif()
# GNU crypto
-if(ENABLE_GCRYPT)
- set(PACKAGELIST ${PACKAGELIST} GCRYPT)
- # Minimum version needed.
- set(GCRYPT_OPTIONS "1.4.2")
-endif()
+set(PACKAGELIST ${PACKAGELIST} GCRYPT)
+# Minimum version needed.
+set(GCRYPT_OPTIONS "1.4.2" REQUIRED)
# GNU SSL/TLS support
if(ENABLE_GNUTLS)
@@ -1571,15 +1569,13 @@ if(WIN32)
"${_dll_output_dir}"
)
endif(LIBSSH_FOUND)
- if(GCRYPT_FOUND)
- foreach( _dll ${GCRYPT_DLLS} )
- add_custom_command(TARGET copy_cli_dlls PRE_BUILD
- COMMAND ${CMAKE_COMMAND} -E copy_if_different
- "${GCRYPT_DLL_DIR}/${_dll}"
- "${_dll_output_dir}"
- )
- endforeach(_dll)
- endif(GCRYPT_FOUND)
+ foreach( _dll ${GCRYPT_DLLS} )
+ add_custom_command(TARGET copy_cli_dlls PRE_BUILD
+ COMMAND ${CMAKE_COMMAND} -E copy_if_different
+ "${GCRYPT_DLL_DIR}/${_dll}"
+ "${_dll_output_dir}"
+ )
+ endforeach(_dll)
if(GNUTLS_FOUND)
foreach( _dll ${GNUTLS_DLLS} )
add_custom_command(TARGET copy_cli_dlls PRE_BUILD