summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2015-05-16 22:26:53 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2015-05-31 18:15:06 +0000
commit7780159c03276d0e35df30f69d9a4806958c764e (patch)
tree4dcdef30a653e2538ec151b407f2b696b5735e5a /CMakeLists.txt
parent7da74dff21d1e41b02cf057fe0fe4c3ea6e9d88d (diff)
downloadwireshark-7780159c03276d0e35df30f69d9a4806958c764e.tar.gz
Fix zlib cmake
Add support for the locally modified version of zlib to suppress a CMake warning and disable building of the zlib examples. Change-Id: I9ae08b49d149951e8626d506f69f1757a1ec7e23 Reviewed-on: https://code.wireshark.org/review/8706 Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c02208753..a1d963ac92 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -697,15 +697,13 @@ endif()
if(ENABLE_ZLIB)
if (WIN32)
# On Windows we build our own version of zlib, so add the paths
- set(ZLIB_SRC_DIR "${_PROJECT_LIB_DIR}/zlib-1.2.8")
+ set(ZLIB_SRC_DIR "${_PROJECT_LIB_DIR}/zlib-1.2.8-ws")
add_subdirectory("${ZLIB_SRC_DIR}" "${CMAKE_BINARY_DIR}/zlib")
set(ZLIB_INCLUDE_DIR "${ZLIB_SRC_DIR}" "${CMAKE_BINARY_DIR}/zlib")
set(ZLIB_LIBRARY zlib)
- # Annoyingly zlib also builds some other stuff we aren't interested in
set_target_properties(zlib PROPERTIES FOLDER "Libs/zlib")
+ # Annoyingly zlib also builds some other stuff we aren't interested in
set_target_properties(zlibstatic PROPERTIES FOLDER "Libs/zlib")
- set_target_properties(example PROPERTIES FOLDER "Libs/zlib")
- set_target_properties(minigzip PROPERTIES FOLDER "Libs/zlib")
endif()
set(PACKAGELIST ${PACKAGELIST} ZLIB)
endif()